GLSA-200806-05 : cbrPager: User-assisted execution of arbitrary code

Medium Nessus Plugin ID 33202


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200806-05 (cbrPager: User-assisted execution of arbitrary code)

Mamoru Tasaka discovered that filenames of the image archives are not properly sanitized before being passed to decompression utilities like unrar and unzip, which use the system() libc library call.
Impact :

A remote attacker could entice a user to open an archive with a specially crafted filename, resulting in arbitrary code execution with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All cbrPager users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-misc/cbrpager-0.9.17'

See Also

Plugin Details

Severity: Medium

ID: 33202

File Name: gentoo_GLSA-200806-05.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2008/06/18

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:cbrpager, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2008/06/16

Reference Information

CVE: CVE-2008-2575

OSVDB: 45685

GLSA: 200806-05

CWE: 94