IBM WebSphere Application Server < Multiple Vulnerabilities

High Nessus Plugin ID 33127


The remote application server is affected by multiple vulnerabilities.


IBM WebSphere Application Server 6.1 before Fix Pack 17 appears to be running on the remote host. As such, it is reportedly affected by multiple flaws :

- An attribute in a SOAP security header may cause a security exposure in Web Services applications.

- An unspecified vulnerability in the native AIO library when running on AIX 5.3 may result in a denial of service when calling into the '' library or the 'getEvent() native method. (PK64529)


If using WebSphere Application Server, apply Fix Pack 17 ( or later.

Otherwise, if using embedded WebSphere Application Server packaged with Tivoli Directory Server, apply the latest recommended eWAS fix pack.

See Also

Plugin Details

Severity: High

ID: 33127

File Name: websphere_6_1_0_17.nasl

Version: $Revision: 1.16 $

Type: remote

Family: Web Servers

Published: 2008/06/10

Modified: 2016/02/04

Dependencies: 57034

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:websphere_application_server

Required KB Items: www/WebSphere

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/06/03

Reference Information

CVE: CVE-2008-2550, CVE-2009-0435

BID: 29543, 33700

OSVDB: 45961, 53271

Secunia: 30526