VMware VIX API Multiple Buffer Overflow Vulnerabilities

high Nessus Plugin ID 33106
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains an application that is affected by multiple buffer overflow vulnerabilities.

Description

VMware VIX, an application programming interface to manipulate virtual machines is installed on the remote host.

The installed version of VMware VIX API is affected by multiple buffer overflow vulnerabilities. Successful exploitation of these issues could allow arbitrary code execution on the host operating system from the guest system.

Solution

Upgrade to VMware VIX API 1.1.4 or higher.

See Also

https://www.vmware.com/security/advisories/VMSA-2008-0009.html

Plugin Details

Severity: High

ID: 33106

File Name: vmware_vix_api_buffer_overflow.nasl

Version: 1.16

Type: local

Agent: windows

Family: Windows

Published: 6/9/2008

Updated: 11/15/2018

Dependencies: smb_hotfixes.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.5

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:ace, cpe:/a:vmware:esx_server, cpe:/o:vmware:esxi, cpe:/a:vmware:fusion, cpe:/a:vmware:player, cpe:/a:vmware:server, cpe:/a:vmware:vmware_workstation

Required KB Items: SMB/Registry/Enumerated

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2008-2100

BID: 29552

VMSA: 2008-0009

CWE: 119