Debian DSA-1590-1 : samba - buffer overflow

High Nessus Plugin ID 32482

Synopsis

The remote Debian host is missing a security-related update.

Description

Alin Rad Pop discovered that Samba contained a buffer overflow condition when processing certain responses received while acting as a client, leading to arbitrary code execution (CVE-2008-1105 ).

Solution

Upgrade the samba packages.

For the stable distribution (etch), this problem has been fixed in version 3.0.24-6etch10.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=483410

https://security-tracker.debian.org/tracker/CVE-2008-1105

https://www.debian.org/security/2008/dsa-1590

Plugin Details

Severity: High

ID: 32482

File Name: debian_DSA-1590.nasl

Version: 1.12

Type: local

Agent: unix

Published: 2008/06/02

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:samba, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2008/05/30

Reference Information

CVE: CVE-2008-1105

DSA: 1590

CWE: 119