Foxit Reader < 2.3 Build 2923 util.printf() Floating Point Specifier RCE

High Nessus Plugin ID 32396


A PDF viewer installed on the remote host is affected by a remote code execution vulnerability.


The version of Foxit Reader installed on the remote Windows host is prior to 2.3 Build 2923. It is, therefore, affected by a boundary error that is triggered when parsing format strings containing a floating point specifier in the util.printf() JavaScript function. An attacker can exploit this issue, by tricking a user into opening a crafted PDF file, to execute arbitrary code with the user's privileges.


Upgrade to Foxit Reader version 2.3 Build 2923 or later.

See Also

Plugin Details

Severity: High

ID: 32396

File Name: foxit_reader_2_3_2912.nasl

Version: $Revision: 1.13 $

Type: local

Agent: windows

Family: Windows

Published: 2008/05/20

Modified: 2016/03/07

Dependencies: 32395

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:foxitsoftware:foxit_reader

Required KB Items: installed_sw/Foxit Reader

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/05/26

Vulnerability Publication Date: 2008/05/20

Exploitable With


Core Impact

Reference Information

CVE: CVE-2008-1104

BID: 29288

OSVDB: 45351

Secunia: 29941

CERT: 119747

CWE: 119