Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : emacs21, emacs22 vulnerabilities (USN-607-1)

Critical Nessus Plugin ID 32187


The remote Ubuntu host is missing one or more security-related patches.


It was discovered that Emacs did not account for precision when formatting integers. If a user were tricked into opening a specially crafted file, an attacker could cause a denial of service or possibly other unspecified actions. This issue does not affect Ubuntu 8.04.

Steve Grubb discovered that the vcdiff script as included in Emacs created temporary files in an insecure way when used with SCCS. Local users could exploit a race condition to create or overwrite files with the privileges of the user invoking the program. (CVE-2008-1694).

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: Critical

ID: 32187

File Name: ubuntu_USN-607-1.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2008/05/09

Modified: 2016/12/01

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:emacs, p-cpe:/a:canonical:ubuntu_linux:emacs-el, p-cpe:/a:canonical:ubuntu_linux:emacs-nox, p-cpe:/a:canonical:ubuntu_linux:emacs21, p-cpe:/a:canonical:ubuntu_linux:emacs21-bin-common, p-cpe:/a:canonical:ubuntu_linux:emacs21-common, p-cpe:/a:canonical:ubuntu_linux:emacs21-el, p-cpe:/a:canonical:ubuntu_linux:emacs21-nox, p-cpe:/a:canonical:ubuntu_linux:emacs22, p-cpe:/a:canonical:ubuntu_linux:emacs22-bin-common, p-cpe:/a:canonical:ubuntu_linux:emacs22-common, p-cpe:/a:canonical:ubuntu_linux:emacs22-el, p-cpe:/a:canonical:ubuntu_linux:emacs22-gtk, p-cpe:/a:canonical:ubuntu_linux:emacs22-nox, cpe:/o:canonical:ubuntu_linux:6.06:-:lts, cpe:/o:canonical:ubuntu_linux:7.04, cpe:/o:canonical:ubuntu_linux:7.10, cpe:/o:canonical:ubuntu_linux:8.04:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2008/05/06

Reference Information

CVE: CVE-2007-6109, CVE-2008-1694

OSVDB: 43372, 44566

USN: 607-1

CWE: 59, 119