GLSA-200805-04 : eGroupWare: Multiple vulnerabilities

Critical Nessus Plugin ID 32152


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200805-04 (eGroupWare: Multiple vulnerabilities)

A vulnerability has been reported in FCKEditor due to the way that file uploads are handled in the file editor/filemanager/upload/php/upload.php when a filename has multiple file extensions (CVE-2008-2041). Another vulnerability exists in the
_bad_protocol_once() function in the file phpgwapi/inc/, which allows remote attackers to bypass HTML filtering (CVE-2008-1502).
Impact :

The first vulnerability can be exploited to upload malicious files and execute arbitrary PHP code provided that a directory is writable by the webserver. The second vulnerability can be exploited by remote attackers via a specially crafted URL in order to conduct cross-site scripting attacks.
Workaround :

There is no known workaround at this time.


All eGroupWare users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/egroupware-1.4.004'

See Also

Plugin Details

Severity: Critical

ID: 32152

File Name: gentoo_GLSA-200805-04.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2008/05/09

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:egroupware, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/05/07

Exploitable With

CANVAS (D2ExploitPack)

Elliot (Moodle <= 1.8.4 RCE)

Reference Information

CVE: CVE-2008-1502, CVE-2008-2041

OSVDB: 43677

GLSA: 200805-04

CWE: 79, 94