GLSA-200805-03 : Multiple X11 terminals: Local privilege escalation

Medium Nessus Plugin ID 32151

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200805-03 (Multiple X11 terminals: Local privilege escalation)

Bernhard R. Link discovered that RXVT opens a terminal on :0 if the '-display' option is not specified and the DISPLAY environment variable is not set. Further research by the Gentoo Security Team has shown that aterm, Eterm, Mrxvt, multi-aterm, rxvt-unicode, and wterm are also affected.
Impact :

A local attacker could exploit this vulnerability to hijack X11 terminals of other users.
Workaround :

There is no known workaround at this time.

Solution

All aterm users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-terms/aterm-1.0.1-r1' All Eterm users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-terms/eterm-0.9.4-r1' All Mrxvt users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-terms/mrxvt-0.5.3-r2' All multi-aterm users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-terms/multi-aterm-0.2.1-r1' All RXVT users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-terms/rxvt-2.7.10-r4' All rxvt-unicode users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-terms/rxvt-unicode-9.02-r1' All wterm users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-terms/wterm-6.2.9-r3'

See Also

https://security.gentoo.org/glsa/200805-03

Plugin Details

Severity: Medium

ID: 32151

File Name: gentoo_GLSA-200805-03.nasl

Version: 1.14

Type: local

Published: 2008/05/09

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:aterm, p-cpe:/a:gentoo:linux:eterm, p-cpe:/a:gentoo:linux:mrxvt, p-cpe:/a:gentoo:linux:multi-aterm, p-cpe:/a:gentoo:linux:rxvt, p-cpe:/a:gentoo:linux:rxvt-unicode, p-cpe:/a:gentoo:linux:wterm, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2008/05/07

Reference Information

CVE: CVE-2008-1142, CVE-2008-1692

GLSA: 200805-03

CWE: 264