Debian DSA-1566-1 : cpio - programming error

high Nessus Plugin ID 32140
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Dmitry Levin discovered a vulnerability in path handling code used by the cpio archive utility. The weakness could enable a denial of service (crash) or potentially the execution of arbitrary code if a vulnerable version of cpio is used to extract or to list the contents of a maliciously crafted archive.

Solution

Upgrade the cpio packages.

For the stable distribution (etch), these problems have been fixed in version 2.6-18.1+etch1.

See Also

https://www.debian.org/security/2008/dsa-1566

Plugin Details

Severity: High

ID: 32140

File Name: debian_DSA-1566.nasl

Version: 1.15

Type: local

Agent: unix

Published: 5/9/2008

Updated: 1/4/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:cpio, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/2/2008

Reference Information

CVE: CVE-2007-4476

DSA: 1566

CWE: 119