GLSA-200804-29 : Comix: Multiple vulnerabilities

High Nessus Plugin ID 32075


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200804-29 (Comix: Multiple vulnerabilities)

Comix does not properly sanitize filenames containing shell metacharacters when they are passed to the rar, unrar, or jpegtran programs (CVE-2008-1568). Comix also creates directories with predictable names (CVE-2008-1796).
Impact :

A remote attacker could exploit the first vulnerability by enticing a user to use Comix to open a file with a specially crafted filename, resulting in the execution of arbitrary commands. The second vulnerability could be exploited by a local attacker to cause a Denial of Service by creating a file or directory with the same filename as the predictable filename used by Comix.
Workaround :

There is no known workaround at this time.


All Comix users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-gfx/comix-3.6.4-r1'

See Also

Plugin Details

Severity: High

ID: 32075

File Name: gentoo_GLSA-200804-29.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2008/04/28

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:comix, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2008/04/25

Reference Information

CVE: CVE-2008-1568, CVE-2008-1796

OSVDB: 43921

GLSA: 200804-29

CWE: 20