GLSA-200804-12 : gnome-screensaver: Privilege escalation

Medium Nessus Plugin ID 31959


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200804-12 (gnome-screensaver: Privilege escalation)

gnome-screensaver incorrectly handles the results of the getpwuid() function in the file src/setuid.c when using directory servers (like NIS) during a network outage, a similar issue to GLSA 200705-14.
Impact :

A local user can crash gnome-xscreensaver by preventing network connectivity if the system uses a remote directory service for credentials such as NIS or LDAP, which will unlock the screen.
Workaround :

There is no known workaround at this time.


All gnome-screensaver users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=gnome-extra/gnome-screensaver-2.20.0-r3'

See Also

Plugin Details

Severity: Medium

ID: 31959

File Name: gentoo_GLSA-200804-12.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2008/04/17

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.7

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gnome-screensaver, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2008/04/11

Reference Information

CVE: CVE-2008-0887

OSVDB: 43986

GLSA: 200804-12