Openfire < 3.5.0 Queue Handling Remote DoS

high Nessus Plugin ID 31855
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host contains an application that is prone to a denial of service attack.


The remote host is running Openfire / Wildfire, an instant messaging server supporting the XMPP protocol.

According to its version, the installation of Openfire or Wildfire on the remote host suffers from a denial of service vulnerability that could bring the server down because it has no limit on a client session's send buffer and can not handle clients that fail to read messages.


Upgrade to Openfire version 3.5.0 or later.

See Also

Plugin Details

Severity: High

ID: 31855

File Name: openfire_3_5_0.nasl

Version: 1.18

Type: remote

Published: 4/11/2008

Updated: 11/15/2018

Dependencies: http_version.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Low

Score: 3.4


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:igniterealtime:openfire

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2008-1728

BID: 28722

Secunia: 29751

CWE: 399