VLC Media Player < 0.8.6f Multiple Vulnerabilities

High Nessus Plugin ID 31853


The remote Windows host contains a media player that is affected by several vulnerabilities.


The version of VLC Media Player installed on the remote host reportedly is affected by several security issues :

- A subtitle buffer overflow (CVE-2007-6681).

- A Real RTSP code execution problem (CVE-2008-0073).

- MP4 integer overflows (CVE-2008-1489).

- A cinepak integer overflow.


Upgrade to VLC Media Player version 0.8.6f or later.

See Also


Plugin Details

Severity: High

ID: 31853

File Name: vlc_0_8_6f.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2008/04/11

Modified: 2016/11/29

Dependencies: 31852

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: true

Exploit Ease: Exploits are available

Exploitable With

Core Impact

Reference Information

CVE: CVE-2007-6681, CVE-2008-1489

BID: 27015, 28433

OSVDB: 42207, 43702

CWE: 119, 189