Fedora 7 : mod_suphp-0.6.3-1.fc7 (2008-2815)

Medium Nessus Plugin ID 31743


The remote Fedora host is missing a security update.


This update is a security update fixing two local privilege escalation problems. mod_suphp 0.6.2 contains two race condition regarding symlink checks. Using this attack vector a local attacker has the ability of changing symlinks in the timeframe between the security check and the php execution itself, leading suphp to execute code as another local user. These have been fixed in the 0.6.3 update with no further code changes being present making a backport of the security fix unnecessary.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected mod_suphp package.

See Also



Plugin Details

Severity: Medium

ID: 31743

File Name: fedora_2008-2815.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2008/04/04

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:L/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:mod_suphp, cpe:/o:fedoraproject:fedora:7

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2008/04/01

Reference Information

CVE: CVE-2008-1614

FEDORA: 2008-2815

CWE: 264