Apache-SSL ExpandCert() Function Certificate Handling Arbitrary Environment Variables Manipulation

High Nessus Plugin ID 31738


The remote web server is prone to a memory disclosure / privilege escalation attack.


According to its banner, the version of Apache-SSL running on the remote host is older than apache_1.3.41+ssl_1.59. Such versions fail to properly sanitize certificate data before using it to populate environment variables. By sending a client certificate with special characters for the subject, a remote attacker can overwrite certain environment variables used by the web server, resulting in memory disclosure or potential privilege escalation in a web application.


Upgrade to apache_1.3.41+ssl_1.59 or later.

See Also




Plugin Details

Severity: High

ID: 31738

File Name: apache_ssl_env_var_manipulation.nasl

Version: $Revision: 1.12 $

Type: remote

Family: Web Servers

Published: 2008/04/03

Modified: 2018/01/22

Dependencies: 48204

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:apache-ssl:apache-ssl

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2008-0555

BID: 28576

OSVDB: 43997

Secunia: 29644

CWE: 20, 287