Apache-SSL ExpandCert() Function Certificate Handling Arbitrary Environment Variables Manipulation

High Nessus Plugin ID 31738


The remote web server is prone to a memory disclosure / privilege escalation attack.


According to its banner, the version of Apache-SSL running on the remote host is older than apache_1.3.41+ssl_1.59. Such versions fail to properly sanitize certificate data before using it to populate environment variables. By sending a client certificate with special characters for the subject, a remote attacker can overwrite certain environment variables used by the web server, resulting in memory disclosure or potential privilege escalation in a web application.


Upgrade to apache_1.3.41+ssl_1.59 or later.

See Also




Plugin Details

Severity: High

ID: 31738

File Name: apache_ssl_env_var_manipulation.nasl

Version: 1.15

Type: remote

Family: Web Servers

Published: 2008/04/03

Updated: 2018/11/15

Dependencies: 48204

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache-ssl:apache-ssl

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2008-0555

BID: 28576

Secunia: 29644

CWE: 20, 287