Apache < 2.0.59 mod_rewrite LDAP Protocol URL Handling Overflow

High Nessus Plugin ID 31655


The remote version of Apache is vulnerable to an off-by-one buffer overflow attack.


The remote host appears to be running a version of Apache that is older than 2.0.59.

This version contains an off-by-one buffer overflow in the mod_rewrite module.


Upgrade to version 2.0.59 or later.

See Also



Plugin Details

Severity: High

ID: 31655

File Name: apache_2_0_59.nasl

Version: 1.28

Type: remote

Family: Web Servers

Published: 2008/03/26

Updated: 2018/11/15

Dependencies: 48204

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2006/07/28

Exploitable With

Core Impact

Metasploit (Apache Module mod_rewrite LDAP Protocol Buffer Overflow)

Reference Information

CVE: CVE-2006-3747

BID: 19204

CWE: 189