VLC Media Player network/httpd.c httpd_FileCallBack Function Connection Parameter Format String

High Nessus Plugin ID 31642


The remote VLC web server is affected by a format string vulnerability.


The remote host is running VLC, a popular media player application which can have an embedded web server.

The remote version of this software is vulnerable to a format string attack when processing a malformed 'Connection:' http header.

An attacker can exploit this flaw to execute arbitrary commands with the privileges of the VLC application.


Upgrade to VLC 0.8.6e or later.

Plugin Details

Severity: High

ID: 31642

File Name: vlc_0_8_6d_format_string.nasl

Version: $Revision: 1.14 $

Type: remote

Published: 2008/03/21

Modified: 2011/04/13

Dependencies: 10107

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2007-6682

BID: 27015

OSVDB: 42208