Ubuntu 6.06 LTS / 6.10 / 7.04 / 7.10 : python2.4/2.5 vulnerabilities (USN-585-1)

Medium Nessus Plugin ID 31461


The remote Ubuntu host is missing one or more security-related patches.


Piotr Engelking discovered that strxfrm in Python was not correctly calculating the size of the destination buffer. This could lead to small information leaks, which might be used by attackers to gain additional knowledge about the state of a running Python script.

A flaw was discovered in the Python imageop module. If a script using the module could be tricked into processing a specially crafted set of arguments, a remote attacker could execute arbitrary code, or cause the application to crash. (CVE-2007-4965).

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 31461

File Name: ubuntu_USN-585-1.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2008/03/13

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:idle-python2.4, p-cpe:/a:canonical:ubuntu_linux:idle-python2.5, p-cpe:/a:canonical:ubuntu_linux:python2.4, p-cpe:/a:canonical:ubuntu_linux:python2.4-dbg, p-cpe:/a:canonical:ubuntu_linux:python2.4-dev, p-cpe:/a:canonical:ubuntu_linux:python2.4-doc, p-cpe:/a:canonical:ubuntu_linux:python2.4-examples, p-cpe:/a:canonical:ubuntu_linux:python2.4-gdbm, p-cpe:/a:canonical:ubuntu_linux:python2.4-minimal, p-cpe:/a:canonical:ubuntu_linux:python2.4-tk, p-cpe:/a:canonical:ubuntu_linux:python2.5, p-cpe:/a:canonical:ubuntu_linux:python2.5-dbg, p-cpe:/a:canonical:ubuntu_linux:python2.5-dev, p-cpe:/a:canonical:ubuntu_linux:python2.5-doc, p-cpe:/a:canonical:ubuntu_linux:python2.5-examples, p-cpe:/a:canonical:ubuntu_linux:python2.5-minimal, cpe:/o:canonical:ubuntu_linux:6.06:-:lts, cpe:/o:canonical:ubuntu_linux:6.10, cpe:/o:canonical:ubuntu_linux:7.04, cpe:/o:canonical:ubuntu_linux:7.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/03/10

Vulnerability Publication Date: 2007/03/31

Reference Information

CVE: CVE-2007-2052, CVE-2007-4965

BID: 25696

OSVDB: 35247, 40142

USN: 585-1

CWE: 189