GLSA-200803-15 : phpMyAdmin: SQL injection vulnerability

Medium Nessus Plugin ID 31441


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200803-15 (phpMyAdmin: SQL injection vulnerability)

Richard Cunningham reported that phpMyAdmin uses the $_REQUEST variable of $_GET and $_POST as a source for its parameters.
Impact :

An attacker could entice a user to visit a malicious web application that sets an 'sql_query' cookie and is hosted on the same domain as phpMyAdmin, and thereby conduct SQL injection attacks with the privileges of the user authenticating in phpMyAdmin afterwards.
Workaround :

There is no known workaround at this time.


All phpMyAdmin users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-db/phpmyadmin-2.11.5'

See Also

Plugin Details

Severity: Medium

ID: 31441

File Name: gentoo_GLSA-200803-15.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2008/03/13

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:phpmyadmin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/03/09

Reference Information

CVE: CVE-2008-1149

BID: 28068

OSVDB: 43051

GLSA: 200803-15

CWE: 89, 352