MS08-017: Vulnerabilities in Microsoft Office Web Components Could Allow Remote Code Execution (933103)

High Nessus Plugin ID 31416


Arbitrary code can be executed on the remote host through Microsoft Office Web Components.


The remote host is running a version of Microsoft Office Web Components that is subject to various flaws that could allow arbitrary code to be run.

An attacker may use this to execute arbitrary code on this host.

To succeed, the attacker would have to send specially crafted URLS to a user of the remote computer and have it process it with Microsoft Office Web Components.


Microsoft has released a set of patches for Office 2000, XP and 2003.

See Also

Plugin Details

Severity: High

ID: 31416

File Name: smb_nt_ms08-017.nasl

Version: $Revision: 1.30 $

Type: local

Agent: windows

Published: 2008/03/11

Modified: 2017/08/10

Dependencies: 13855, 57033

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:office, cpe:/a:microsoft:biztalk_server, cpe:/, cpe:/a:microsoft:commerce_server

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/03/11

Vulnerability Publication Date: 2008/03/11

Exploitable With

CANVAS (D2ExploitPack)

Core Impact

Reference Information

CVE: CVE-2006-4695, CVE-2007-1201

BID: 28135, 28136

OSVDB: 42711, 42712

CERT: 654577

MSFT: MS08-017

MSKB: 933103

CWE: 94