Apache 1.3.x < 1.3.41 Multiple Vulnerabilities (DoS, XSS)

Medium Nessus Plugin ID 31408

Synopsis

The remote web server may be affected by several issues.

Description

According to its banner, the version of Apache 1.3.x running on the remote host is prior to 1.3.41. It is, therefore, affected by multiple vulnerabilities :

- A denial of service issue in mod_proxy when parsing date-related headers. (CVE-2007-3847)

- A cross-site scripting issue involving mod_imap.
(CVE-2007-5000).

- A cross-site scripting issue in mod_status involving the refresh parameter. (CVE-2007-6388)

- A cross-site scripting issue using UTF-7 encoding in mod_proxy_ftp exists because it does not define a charset. (CVE-2008-0005)

Note that the remote web server may not actually be affected by these vulnerabilities. Nessus did not try to determine whether the affected modules are in use or to check for the issues themselves.

Solution

Upgrade to Apache version 1.3.41 or later. Alternatively, ensure that the affected modules are not in use.

See Also

https://www.securityfocus.com/archive/1/archive/1/486167/100/0/threaded

https://archive.apache.org/dist/httpd/CHANGES_1.3.41

Plugin Details

Severity: Medium

ID: 31408

File Name: apache_1_3_41.nasl

Version: 1.30

Type: remote

Family: Web Servers

Published: 2008/03/07

Updated: 2018/11/15

Dependencies: 48204

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2007/08/01

Reference Information

CVE: CVE-2007-3847, CVE-2007-5000, CVE-2007-6388, CVE-2008-0005

BID: 25489, 26838, 27234, 27237

CWE: 79