Apache < 2.0.63 Multiple XSS Vulnerabilities

Medium Nessus Plugin ID 31407


The remote web server is affected by multiple cross-site scripting vulnerabilities.


According to its banner, the version of Apache 2.0.x running on the remote host is prior to 2.0.63. It is, therefore, affected by multiple cross-site scripting vulnerabilities :

- A cross-site scripting issue involving mod_imap.

- A cross-site scripting issue involving 413 error pages via a malformed HTTP method. (PR 44014 / CVE-2007-6203)

- A cross-site scripting issue in mod_status involving the refresh parameter. (CVE-2007-6388)

- A cross-site scripting issue using UTF-7 encoding in mod_proxy_ftp exists because it does not define a charset. (CVE-2008-0005)

Note that the remote web server may not actually be affected by these vulnerabilities. Nessus did not try to determine whether the affected modules are in use or to check for the issues themselves.


Upgrade to Apache version 2.0.63 or later. Alternatively, ensure that he affected modules are not in use.

See Also



Plugin Details

Severity: Medium

ID: 31407

File Name: apache_2_0_63.nasl

Version: 1.30

Type: remote

Family: Web Servers

Published: 2008/03/07

Updated: 2018/06/29

Dependencies: 48204

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2007/11/14

Reference Information

CVE: CVE-2007-5000, CVE-2007-6203, CVE-2007-6388, CVE-2008-0005

BID: 26663, 26838, 27234, 27237

CWE: 79