GLSA-200803-10 : lighttpd: Multiple vulnerabilities

Medium Nessus Plugin ID 31385


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200803-10 (lighttpd: Multiple vulnerabilities)

lighttpd contains a calculation error when allocating the global file descriptor array (CVE-2008-0983). Furthermore, it sends the source of a CGI script instead of returning a 500 error (Internal Server Error) when the fork() system call fails (CVE-2008-1111).
Impact :

A remote attacker could exploit these vulnerabilities to cause a Denial of Service or gain the source of a CGI script.
Workaround :

There is no known workaround at this time.


All lighttpd users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-servers/lighttpd-1.4.18-r2'

See Also

Plugin Details

Severity: Medium

ID: 31385

File Name: gentoo_GLSA-200803-10.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2008/03/07

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:lighttpd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2008/03/05

Reference Information

CVE: CVE-2008-0983, CVE-2008-1111

OSVDB: 42363, 43169

GLSA: 200803-10

CWE: 200, 399