Learn2 STRunner ActiveX Control Multiple Buffer Overflow Vulnerabilities

High Nessus Plugin ID 31352


The remote Windows host has an ActiveX control that is susceptible to multiple buffer overflow attacks.


The Learn2 Corporation's STRunner ActiveX control, used with various online tutorials, is installed on the remote host. It reportedly is affected by multiple and as-yet unspecified stack-based buffer overflows. If a remote attacker can trick a user on the affected host into visiting a specially crafted web page, this issue could be leveragedto execute arbitrary code on the affected host subject to the user's privileges.


Unknown at this time.

Plugin Details

Severity: High

ID: 31352

File Name: learn2_strunner_overflows.nasl

Version: $Revision: 1.13 $

Type: local

Agent: windows

Family: Windows

Published: 2008/03/05

Modified: 2014/06/05

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:W/RC:ND

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2007-6252

BID: 28058

OSVDB: 42554

CERT: 524857

CWE: 119