GLSA-200802-05 : Gnumeric: User-assisted execution of arbitrary code

High Nessus Plugin ID 31083


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200802-05 (Gnumeric: User-assisted execution of arbitrary code)

Multiple integer overflow and signedness errors have been reported in the excel_read_HLINK() function in file plugins/excel/ms-excel-read.c when processing XLS HLINK opcodes.
Impact :

A remote attacker could entice a user to open a specially crafted XLS file, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All Gnumeric users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/gnumeric-1.8.1'

See Also

Plugin Details

Severity: High

ID: 31083

File Name: gentoo_GLSA-200802-05.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2008/02/14

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gnumeric, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2008/02/12

Reference Information

CVE: CVE-2008-0668

OSVDB: 42835

GLSA: 200802-05

CWE: 189