MS08-012: Vulnerability in Microsoft Publisher Could Allow Remote Code Execution (947085)

High Nessus Plugin ID 31046


Arbitrary code can be executed on the remote host through Microsoft Publisher.


The remote host is running a version of Microsoft Publisher that may allow arbitrary code to be run on this host.

To succeed, the attacker would have to send a rogue file to a user of the remote computer and have him open it. Then a bug in the font parsing handler would result in code execution.


Microsoft has released a set of patches for Publisher 2000, XP and 2003.

See Also

Plugin Details

Severity: High

ID: 31046

File Name: smb_nt_ms08-012.nasl

Version: $Revision: 1.32 $

Type: local

Agent: windows

Published: 2008/02/12

Modified: 2017/08/10

Dependencies: 11336, 57033

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:office

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/02/12

Vulnerability Publication Date: 2008/02/12

Reference Information

CVE: CVE-2008-0102, CVE-2008-0104

BID: 27739, 27740

OSVDB: 41446, 41447

MSFT: MS08-012

MSKB: 946216, 946254, 946255

CWE: 94, 399