MS08-006: Vulnerability in Internet Information Services Could Allow Remote Code Execution (942830)

Medium Nessus Plugin ID 31040


It is possible to use the remote web server to exploit arbitrary code on the remote host.


The remote host is running a version of Windows and IIS that is vulnerable to a flaw that could allow an attacker who has the privileges to upload arbitrary ASP scripts to it to execute arbitrary code.

Specifically, the remote version of IIS is vulnerable to a flaw when parsing specially crafted ASP files. By uploading a malicious ASP file on the remote host, an attacker may be able to take the complete control of the remote system.


Microsoft has released a set of patches for Windows XP and 2003.

See Also

Plugin Details

Severity: Medium

ID: 31040

File Name: smb_nt_ms08-006.nasl

Version: $Revision: 1.27 $

Type: local

Agent: windows

Published: 2008/02/12

Modified: 2017/08/10

Dependencies: 13855, 57033

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/02/12

Vulnerability Publication Date: 2008/02/12

Exploitable With

Core Impact

Reference Information

CVE: CVE-2008-0075

BID: 27676

OSVDB: 41445

MSFT: MS08-006

MSKB: 942830

CWE: 94