Debian DSA-1483-1 : net-snmp - design error

high Nessus Plugin ID 30223
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

The SNMP agent (snmp_agent.c) in net-snmp before 5.4.1 allows remote attackers to cause a denial of service (CPU and memory consumption) via a GETBULK request with a large max-repeaters value.

Solution

Upgrade the net-snmp package.

For the stable distribution (etch), this problem has been fixed in version 5.2.3-7etch2.

For the unstable and testing distributions (sid and lenny, respectively), this problem has been fixed in version 5.4.1~dfsg-2.

See Also

https://www.debian.org/security/2008/dsa-1483

Plugin Details

Severity: High

ID: 30223

File Name: debian_DSA-1483.nasl

Version: 1.15

Type: local

Agent: unix

Published: 2/11/2008

Updated: 1/4/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:net-snmp, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2/6/2008

Reference Information

CVE: CVE-2007-5846

DSA: 1483

CWE: 399