Adobe Reader < 7.1.0 / 8.1.2 Multiple Vulnerabilities

high Nessus Plugin ID 30200


The PDF file viewer on the remote Windows host is affected by multiple vulnerabilities.


The version of Adobe Reader installed on the remote host is earlier than 8.1.2 or 7.1.0. Such versions are reportedly affected by multiple vulnerabilities :

- A design error vulnerability may allow an attacker to gain control of a user's printer.

- Multiple stack-based buffer overflows may allow an attacker to execute arbitrary code subject to the user's privileges.

- Insecure loading of 'Security Provider' libraries may allow for arbitrary code execution.

- An insecure method exposed by the JavaScript library in the 'EScript.api' plug-in allows direct control over low-level features of the object, which allows for execution of arbitrary code as the current user.

- Two vulnerabilities in the unpublicized function 'app.checkForUpdate()' exploited through a callback function could lead to arbitrary code execution in Adobe Reader 7.


Upgrade to Adobe Reader 8.1.2 / 7.1.0 or later.

See Also

Plugin Details

Severity: High

ID: 30200

File Name: adobe_reader_812.nasl

Version: 1.37

Type: local

Agent: windows

Family: Windows

Published: 2/6/2008

Updated: 6/8/2022

Supported Sensors: Nessus Agent

Risk Information


Risk Factor: Critical

Score: 9.6


Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2008-2042

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Acroread/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/7/2008

CISA Known Exploited Dates: 6/22/2022

Exploitable With


Core Impact

Metasploit (Adobe Collab.collectEmailInfo() Buffer Overflow)

Reference Information

CVE: CVE-2007-5659, CVE-2007-5663, CVE-2007-5666, CVE-2008-0655, CVE-2008-0667, CVE-2008-0726, CVE-2008-2042

BID: 27641

CWE: 94, 119, 189, 399