Debian DSA-1480-1 : poppler - several vulnerabilities

High Nessus Plugin ID 30188

Synopsis

The remote Debian host is missing a security-related update.

Description

Alin Rad Pop discovered several buffer overflows in the Poppler PDF library, which could allow the execution of arbitrary code if a malformed PDF file is opened.

Solution

Upgrade the poppler packages.

The old stable distribution (sarge) doesn't contain poppler.

For the stable distribution (etch), these problems have been fixed in version 0.4.5-5.1etch2.

See Also

https://www.debian.org/security/2008/dsa-1480

Plugin Details

Severity: High

ID: 30188

File Name: debian_DSA-1480.nasl

Version: 1.11

Type: local

Agent: unix

Published: 2008/02/06

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:poppler, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2008/02/05

Reference Information

CVE: CVE-2007-4352, CVE-2007-5392, CVE-2007-5393

DSA: 1480

CWE: 119