Aurigma Image Uploader ActiveX Control < 4.5.70 Multiple Buffer Overflows

High Nessus Plugin ID 30134


The remote Windows host has an ActiveX control that is affected by multiple buffer overflow vulnerabilities.


The remote host contains a version of the Aurigma Image Uploader ActiveX control that is reportedly affected by multiple stack buffer overflows. If a remote attacker can trick a user on the affected host into visiting a specially crafted web page, this issue could be leveraged to execute arbitrary code on the affected host subject to the user's privileges.


Upgrade to Aurigma Image Uploader version 4.5.70 or later

See Also

Plugin Details

Severity: High

ID: 30134

File Name: image_uploader_4_5_70_activex_overflows.nasl

Version: $Revision: 1.13 $

Type: local

Agent: windows

Family: Windows

Published: 2008/01/31

Modified: 2016/10/27

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

BID: 26537

OSVDB: 50857