SwiftView Viewer Plugin < 8.3.5 Buffer Overflow

High Nessus Plugin ID 30133


The remote Windows host contains a browser enhancement that is affected by a buffer overflow.


A SwiftView Viewer ActiveX control and/or browser plug-in is installed on the remote Windows host. SwiftView Viewer is an application for viewing and printing print streams.

According to its version, the SwiftView ActiveX control / browser plug-in currently installed is affected by a stack-based buffer overflow. If a remote attacker can trick a user on the affected host into visiting a specially crafted web page, this issue could be leveraged to execute arbitrary code on the affected host subject to the user's privileges.


Upgrade to SwiftView Viewer version 8.3.5 or later.

See Also


Plugin Details

Severity: High

ID: 30133

File Name: swiftview_8_3_5_overflow.nasl

Version: $Revision: 1.15 $

Type: local

Agent: windows

Family: Windows

Published: 2008/01/31

Modified: 2015/01/12

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2007-5602

BID: 27527

OSVDB: 42836, 42837

CERT: 639169

CWE: 119