CentOS 3 : wireshark (CESA-2008:0059)

Critical Nessus Plugin ID 30044

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated wireshark packages that fix several security issues are now available for Red Hat Enterprise Linux 3.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

Wireshark is a program for monitoring network traffic. Wireshark was previously known as Ethereal.

Several flaws were found in Wireshark. Wireshark could crash or possibly execute arbitrary code as the user running Wireshark if it read a malformed packet off the network. (CVE-2007-6114, CVE-2007-6115, CVE-2007-6117)

Several denial of service bugs were found in Wireshark. Wireshark could crash or stop responding if it read a malformed packet off the network. (CVE-2007-3389, CVE-2007-3390, CVE-2007-3391, CVE-2007-3392, CVE-2007-3392, CVE-2007-3393, CVE-2007-6113, CVE-2007-6118, CVE-2007-6120, CVE-2007-6121, CVE-2007-6450, CVE-2007-6451)

As well, Wireshark switched from using net-snmp to libsmi, which is included in this errata.

Users of wireshark should upgrade to these updated packages, which contain Wireshark version 0.99.7, and resolve these issues.

Solution

Update the affected wireshark packages.

See Also

http://www.nessus.org/u?22d27ace

http://www.nessus.org/u?3853ddf8

http://www.nessus.org/u?496d5c10

Plugin Details

Severity: Critical

ID: 30044

File Name: centos_RHSA-2008-0059.nasl

Version: 1.19

Type: local

Agent: unix

Published: 2008/01/22

Updated: 2019/10/03

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:libsmi, p-cpe:/a:centos:centos:libsmi-devel, p-cpe:/a:centos:centos:wireshark, p-cpe:/a:centos:centos:wireshark-gnome, cpe:/o:centos:centos:3

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/01/21

Vulnerability Publication Date: 2007/06/25

Reference Information

CVE: CVE-2007-3389, CVE-2007-3390, CVE-2007-3391, CVE-2007-3392, CVE-2007-3393, CVE-2007-6113, CVE-2007-6114, CVE-2007-6115, CVE-2007-6117, CVE-2007-6118, CVE-2007-6120, CVE-2007-6121, CVE-2007-6450, CVE-2007-6451

BID: 24662, 26532, 27071

RHSA: 2008:0059

CWE: 20, 119, 189, 399