Debian DSA-1455-1 : libarchive - denial of service

High Nessus Plugin ID 29902

Synopsis

The remote Debian host is missing a security-related update.

Description

Several local/remote vulnerabilities have been discovered in libarchive1, a single library to read/write tar, cpio, pax, zip, iso9660 archives. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2007-3641 It was discovered that libarchive1 would miscompute the length of a buffer resulting in a buffer overflow if yet another type of corruption occurred in a pax extension header.

- CVE-2007-3644 It was discovered that if an archive prematurely ended within a pax extension header the libarchive1 library could enter an infinite loop.

- CVE-2007-3645 If an archive prematurely ended within a tar header, immediately following a pax extension header, libarchive1 could dereference a NULL pointer.

Solution

Upgrade the libarchive package.

The old stable distribution (sarge), does not contain this package.

For the stable distribution (etch), these problems have been fixed in version 1.2.53-2etch1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=432924

https://security-tracker.debian.org/tracker/CVE-2007-3641

https://security-tracker.debian.org/tracker/CVE-2007-3644

https://security-tracker.debian.org/tracker/CVE-2007-3645

https://www.debian.org/security/2008/dsa-1455

Plugin Details

Severity: High

ID: 29902

File Name: debian_DSA-1455.nasl

Version: 1.14

Type: local

Agent: unix

Published: 2008/01/10

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libarchive1, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2008/01/08

Reference Information

CVE: CVE-2007-3641, CVE-2007-3644, CVE-2007-3645

DSA: 1455