Debian DSA-1453-1 : tomcat5 - several vulnerabilities

Medium Nessus Plugin ID 29872

Synopsis

The remote Debian host is missing a security-related update.

Description

Several remote vulnerabilities have been discovered in the Tomcat servlet and JSP engine. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2007-3382 It was discovered that single quotes (') in cookies were treated as a delimiter, which could lead to an information leak.

- CVE-2007-3385 It was discovered that the character sequence \' in cookies was handled incorrectly, which could lead to an information leak.

- CVE-2007-5461 It was discovered that the WebDAV servlet is vulnerable to absolute path traversal.

Solution

Upgrade the tomcat5 packages.

The old stable distribution (sarge) doesn't contain tomcat5.

For the stable distribution (etch), these problems have been fixed in version 5.0.30-12etch1.

See Also

https://security-tracker.debian.org/tracker/CVE-2007-3382

https://security-tracker.debian.org/tracker/CVE-2007-3385

https://security-tracker.debian.org/tracker/CVE-2007-5461

https://www.debian.org/security/2008/dsa-1453

Plugin Details

Severity: Medium

ID: 29872

File Name: debian_DSA-1453.nasl

Version: 1.14

Type: local

Agent: unix

Published: 2008/01/08

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:tomcat5, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2008/01/07

Reference Information

CVE: CVE-2007-3382, CVE-2007-3385, CVE-2007-5461

DSA: 1453

CWE: 22, 200