GLSA-200712-24 : AMD64 x86 emulation GTK+ library: User-assisted execution of arbitrary code

Medium Nessus Plugin ID 29821


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200712-24 (AMD64 x86 emulation GTK+ library: User-assisted execution of arbitrary code)

The Cairo versions used by the AMD64 x86 emulation GTK+ libraries were vulnerable to integer overflow vulnerabilities (GLSA 200712-04).
Impact :

A remote attacker could entice a user to view or process a specially crafted PNG image file in an application linked against Cairo, possibly leading to the execution of arbitrary code with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All AMD64 x86 emulation GTK+ library users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-emulation/emul-linux-x86-gtklibs-20071214'

See Also

Plugin Details

Severity: Medium

ID: 29821

File Name: gentoo_GLSA-200712-24.nasl

Version: $Revision: 1.17 $

Type: local

Published: 2007/12/31

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:ND/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:emul-linux-x86-gtklibs, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list, Host/Gentoo/arch

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/12/30

Reference Information

BID: 26650

OSVDB: 39242

GLSA: 200712-24