GLSA-200712-18 : Multi-Threaded DAAP Daemon: Multiple vulnerabilities

High Nessus Plugin ID 29815


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200712-18 (Multi-Threaded DAAP Daemon: Multiple vulnerabilities)

nnp discovered multiple vulnerabilities in the XML-RPC handler in the file webserver.c. The ws_addarg() function contains a format string vulnerability, as it does not properly sanitize username and password data from the 'Authorization: Basic' HTTP header line (CVE-2007-5825).
The ws_decodepassword() and ws_getheaders() functions do not correctly handle empty Authorization header lines, or header lines without a ':' character, leading to NULL pointer dereferences (CVE-2007-5824).
Impact :

A remote attacker could send specially crafted HTTP requests to the web server in the Multi-Threaded DAAP Daemon, possibly leading to the execution of arbitrary code with the privileges of the user running the web server or a Denial of Service.
Workaround :

There is no known workaround at this time.


All Multi-Threaded DAAP Daemon users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-sound/mt-daapd-'

See Also

Plugin Details

Severity: High

ID: 29815

File Name: gentoo_GLSA-200712-18.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2007/12/31

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mt-daapd, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/12/29

Exploitable With

Core Impact

Reference Information

CVE: CVE-2007-5824, CVE-2007-5825

BID: 26310

OSVDB: 45286

GLSA: 200712-18

CWE: 20, 134