Debian DSA-1438-1 : tar - several vulnerabilities

high Nessus Plugin ID 29805

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in GNU Tar. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2007-4131 A directory traversal vulnerability enables attackers using specially crafted archives to extract contents outside the directory tree created by tar.

- CVE-2007-4476 A stack-based buffer overflow in the file name checking code may lead to arbitrary code execution when processing maliciously crafted archives.

Solution

Upgrade the tar package.

For the old stable distribution (sarge), these problems have been fixed in version 1.14-2.4.

For the stable distribution (etch), these problems have been fixed in version 1.16-2etch1.

See Also

https://security-tracker.debian.org/tracker/CVE-2007-4131

https://security-tracker.debian.org/tracker/CVE-2007-4476

https://www.debian.org/security/2007/dsa-1438

Plugin Details

Severity: High

ID: 29805

File Name: debian_DSA-1438.nasl

Version: 1.20

Type: local

Agent: unix

Published: 12/31/2007

Updated: 1/4/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:tar, cpe:/o:debian:debian_linux:3.1, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/28/2007

Reference Information

CVE: CVE-2007-4131, CVE-2007-4476

BID: 25417, 26445

DSA: 1438

CWE: 119