Debian DSA-1437-1 : cupsys - several vulnerabilities

High Nessus Plugin ID 29803

Synopsis

The remote Debian host is missing a security-related update.

Description

Several local vulnerabilities have been discovered in the Common UNIX Printing System. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2007-5849 Wei Wang discovered that an buffer overflow in the SNMP backend may lead to the execution of arbitrary code.

- CVE-2007-6358 Elias Pipping discovered that insecure handling of a temporary file in the pdftops.pl script may lead to local denial of service. This vulnerability is not exploitable in the default configuration.

Solution

Upgrade the cupsys packages.

The old stable distribution (sarge) is not affected by CVE-2007-5849.
The other issue doesn't warrant an update on it's own and has been postponed.

For the stable distribution (etch), these problems have been fixed in version 1.2.7-4etch2.

See Also

https://security-tracker.debian.org/tracker/CVE-2007-5849

https://security-tracker.debian.org/tracker/CVE-2007-6358

https://security-tracker.debian.org/tracker/CVE-2007-5849

https://www.debian.org/security/2007/dsa-1437

Plugin Details

Severity: High

ID: 29803

File Name: debian_DSA-1437.nasl

Version: 1.17

Type: local

Agent: unix

Published: 2007/12/27

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:cupsys, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2007/12/26

Reference Information

CVE: CVE-2007-5849, CVE-2007-6358

DSA: 1437

CWE: 189