3ivx MPEG-4 < 5.0.2 Buffer Overflow

High Nessus Plugin ID 29749


The remote Windows host contains an application that is prone to a buffer overflow attack.


The 3ivx MPEG-4 compression suite is installed on the remote host. It contains an MP4 codec for use with media players such as Windows Media Player for creating and playing back MPEG-4 / MP4 files.

The version of this codec on the remote host is affected by a buffer overflow vulnerability. If an attacker can trick a user on the affected host into opening a specially crafted MP4 file with a media player that uses this codec, this issue could be leveraged to execute arbitrary code on the affected host subject to the user's privileges.


Upgrade to 3ivx MPEG-4 compression suite version 5.0.2 or later.

See Also




Plugin Details

Severity: High

ID: 29749

File Name: 3ivx_mpeg4_502.nasl

Version: $Revision: 1.13 $

Type: local

Agent: windows

Family: Windows

Published: 2007/12/24

Modified: 2015/01/12

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2007-6401, CVE-2007-6402

BID: 26773

OSVDB: 42579, 42580

CWE: 119