QuickTime < 7.3.1 Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 29699


The remote Mac OS X host contains an application that is affected by multiple vulnerabilities.


The version of QuickTime installed on the remote Mac OS X host is older than 7.3.1. Such versions contain several vulnerabilities that may allow an attacker to execute arbitrary code on the remote host if he can trick the user to open a specially crafted RTSP movie, QTL file, or Flash media file with QuickTime.


Either use QuickTime's Software Update preference to upgrade to the latest version or manually upgrade to QuickTime 7.3.1 or later.

See Also



Plugin Details

Severity: High

ID: 29699

File Name: macosx_Quicktime731.nasl

Version: $Revision: 1.18 $

Type: local

Agent: macosx

Published: 2007/12/14

Modified: 2016/11/28

Dependencies: 15573

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: MacOSX/QuickTime/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/12/13

Exploitable With


Core Impact

Metasploit (Apple QuickTime 7.3 RTSP Response Header Buffer Overflow)

Reference Information

CVE: CVE-2007-4706, CVE-2007-4707, CVE-2007-6166

BID: 26549, 26866, 26868

OSVDB: 40876, 40883, 40884

CWE: 119