MS07-064: Vulnerabilities in DirectX Could Allow Remote Code Execution (941568)

High Nessus Plugin ID 29308


A vulnerability in DirectX could allow remote code execution.


The remote host contains a version of DirectX that is vulnerable to a remote code execution attack.

To exploit this flaw, an attacker would need to send a malformed AVI, WMV or SAMI file to a user on the remote host and have him open it.


Microsoft has released a set of patches for Windows 2000, XP, 2003 and Vista.

See Also

Plugin Details

Severity: High

ID: 29308

File Name: smb_nt_ms07-064.nasl

Version: $Revision: 1.30 $

Type: local

Agent: windows

Published: 2007/12/11

Modified: 2017/08/10

Dependencies: 13855, 57033

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/12/11

Vulnerability Publication Date: 2007/12/11

Exploitable With

Core Impact

Metasploit (MS07-064 Microsoft DirectX DirectShow SAMI Buffer Overflow)

Reference Information

CVE: CVE-2007-3901, CVE-2007-3895

BID: 26804

OSVDB: 39126, 39127

MSFT: MS07-064

MSKB: 941568

CERT: 321233, 804089

EDB-ID: 4866, 16442

CWE: 119