Mandrake Linux Security Advisory : libnfsidmap (MDKSA-2007:240)

Medium Nessus Plugin ID 29298


The remote Mandrake Linux host is missing one or more security updates.


The NFSv4 ID mapper prior to 0.17 did not properly handle return values from the getpwnam_r() function when performing a username lookup, which could cause it to report a file as being owned by 'root' instead of 'nobody' if the file exists on the server but not the client.

The updated packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 29298

File Name: mandrake_MDKSA-2007-240.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/12/11

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.2

Vector: CVSS2#AV:L/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64nfsidmap0, p-cpe:/a:mandriva:linux:lib64nfsidmap0-devel, p-cpe:/a:mandriva:linux:libnfsidmap0, p-cpe:/a:mandriva:linux:libnfsidmap0-devel, cpe:/o:mandriva:linux:2007

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/12/07

Reference Information

CVE: CVE-2007-4135

MDKSA: 2007:240