GLSA-200712-07 : Lookup: Insecure temporary file creation

Medium Nessus Plugin ID 29294


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200712-07 (Lookup: Insecure temporary file creation)

Tatsuya Kinoshita reported that the ndeb-binary function does not handle temporay files correctly.
Impact :

A local attacker could use a symlink attack to overwrite files with the privileges of the user running Lookup.
Workaround :

There is no known workaround at this time.


All Lookup users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-emacs/lookup-1.4.1'

See Also

Plugin Details

Severity: Medium

ID: 29294

File Name: gentoo_GLSA-200712-07.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2007/12/11

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:lookup, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2007/12/09

Vulnerability Publication Date: 2007/03/18

Reference Information

CVE: CVE-2007-0237

OSVDB: 34263

GLSA: 200712-07