GLSA-200712-04 : Cairo: User-assisted execution of arbitrary code

Medium Nessus Plugin ID 29291


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200712-04 (Cairo: User-assisted execution of arbitrary code)

Multiple integer overflows were reported, one of which Peter Valchev (Google Security) found to be leading to a heap-based buffer overflow in the cairo_image_surface_create_from_png() function that processes PNG images.
Impact :

A remote attacker could entice a user to view or process a specially crafted PNG image file in an application linked against Cairo, possibly leading to the execution of arbitrary code with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All Cairo users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/cairo-1.4.12'

See Also

Plugin Details

Severity: Medium

ID: 29291

File Name: gentoo_GLSA-200712-04.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/12/11

Modified: 2016/05/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:ND/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:cairo, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/12/09

Reference Information

CVE: CVE-2007-5503

BID: 26650

OSVDB: 39242

GLSA: 200712-04

CWE: 189