Mandrake Linux Security Advisory : vixie-cron (MDKSA-2007:234)

Low Nessus Plugin ID 29201


The remote Mandrake Linux host is missing a security update.


Raphael Marichez discovered a denial of service bug in how vixie-cron verifies crontab file integrity. A local user with the ability to create a hardlink to /etc/crontab could prevent vixie-cron from executing certain system cron jobs.

The updated packages have been patched to correct this issue.


Update the affected vixie-cron package.

Plugin Details

Severity: Low

ID: 29201

File Name: mandrake_MDKSA-2007-234.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2007/12/04

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:vixie-cron, cpe:/o:mandriva:linux:2007, cpe:/o:mandriva:linux:2007.1, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2007/12/03

Reference Information

CVE: CVE-2007-1856

MDKSA: 2007:234