Netscape Browser < Multiple Vulnerabilities

High Nessus Plugin ID 28377


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Netscape is affected by various security issues :

- Three bugs that can result in crashes with traces of memory corruption

- A cross-site scripting vulnerability involving support for the 'jar:' URI scheme

- A timing issue when setting the 'window.location' property that could be leveraged to conduct cross-site request forgery attacks.


The Netscape Browser / Navigator has been discontinued. While these issues were reportedly fixed in, it is strongly recommended that you switch to the latest version of another browser, such as Mozilla Firefox, which the Netscape Team recommends.

See Also

Plugin Details

Severity: High

ID: 28377

File Name: netscape_browser_9004.nasl

Version: $Revision: 1.15 $

Type: local

Agent: windows

Family: Windows

Published: 2007/12/03

Modified: 2017/06/12

Dependencies: 19695

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:netscape:navigator

Required KB Items: SMB/Netscape/installed

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2007/11/09

Reference Information

CVE: CVE-2007-5947, CVE-2007-5959, CVE-2007-5960

BID: 26385, 26589, 26593

OSVDB: 38463, 38867, 38868

CWE: 22, 79