GLSA-200711-33 : nss_ldap: Information disclosure

Medium Nessus Plugin ID 28322


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200711-33 (nss_ldap: Information disclosure)

Josh Burley reported that nss_ldap does not properly handle the LDAP connections due to a race condition that can be triggered by multi-threaded applications using nss_ldap, which might lead to requested data being returned to a wrong process.
Impact :

Remote attackers could exploit this race condition by sending queries to a vulnerable server using nss_ldap, possibly leading to theft of user credentials or information disclosure (e.g. Dovecot returning wrong mailbox contents).
Workaround :

There is no known workaround at this time.


All nss_ldap users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-auth/nss_ldap-258'

See Also

Plugin Details

Severity: Medium

ID: 28322

File Name: gentoo_GLSA-200711-33.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2007/11/26

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:nss_ldap, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/11/25

Reference Information

CVE: CVE-2007-5794

BID: 26452

OSVDB: 42223

GLSA: 200711-33

CWE: 362