Debian DSA-1408-1 : kdegraphics - buffer overflow

High Nessus Plugin ID 28297

Synopsis

The remote Debian host is missing a security-related update.

Description

Alin Rad Pop discovered a buffer overflow in kpdf, which could allow the execution of arbitrary code if a malformed PDF file is displayed.

The old stable distribution (sarge) will be fixed later.

Solution

Upgrade the kdegraphics packages.

For the stable distribution (etch), this problem has been fixed in version 4:3.5.5-3etch2. Builds for arm and sparc are not yet available.

See Also

https://www.debian.org/security/2007/dsa-1408

Plugin Details

Severity: High

ID: 28297

File Name: debian_DSA-1408.nasl

Version: 1.12

Type: local

Agent: unix

Published: 2007/11/26

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:kdegraphics, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2007/11/21

Reference Information

CVE: CVE-2007-5393

DSA: 1408

CWE: 119