RHEL 4 : xterm (RHSA-2007:0701)

Low Nessus Plugin ID 28236


The remote Red Hat host is missing a security update.


An updated xterm package that corrects a security issue is now available for Red Hat Enterprise Linux 4.

This update has been rated as having low security impact by the Red Hat Security Response Team.

The xterm program is a terminal emulator for the X Window System. It provides DEC VT102 and Tektronix 4014 compatible terminals for programs that cannot use the window system directly.

A bug was found in the way xterm packages were built that caused the pseudo-terminal device files of the xterm emulated terminals to be owned by the incorrect group. This flaw did not affect Red Hat Enterprise Linux 4 Update 4 and earlier. (CVE-2007-2797)

All users of xterm are advised to upgrade to this updated package, which contains a patch to correct this issue.


Update the affected xterm package.

See Also



Plugin Details

Severity: Low

ID: 28236

File Name: redhat-RHSA-2007-0701.nasl

Version: $Revision: 1.15 $

Type: local

Agent: unix

Published: 2007/11/16

Modified: 2016/12/29

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:xterm, cpe:/o:redhat:enterprise_linux:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2007/11/15

Reference Information

CVE: CVE-2007-2797

OSVDB: 43308

RHSA: 2007:0701